summary refs log tree commit diff
path: root/nixos/tests/nfs.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-11 17:15:56 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-11 17:16:44 +0200
commit13185280fee4111dc07f794e528fa3a73f421f3a (patch)
tree40f813ae0cf436e9bbe3a8364b046c6f93ffc2fc /nixos/tests/nfs.nix
parent017408e048ae2419baf0adba424b51d85b063a30 (diff)
downloadnixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.gz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.bz2
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.lz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.xz
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.tar.zst
nixlib-13185280fee4111dc07f794e528fa3a73f421f3a.zip
Fix tests broken due to the firewall being enabled by default
Diffstat (limited to 'nixos/tests/nfs.nix')
-rw-r--r--nixos/tests/nfs.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/tests/nfs.nix b/nixos/tests/nfs.nix
index 51abf57e1b75..7bc99aef3b5e 100644
--- a/nixos/tests/nfs.nix
+++ b/nixos/tests/nfs.nix
@@ -13,6 +13,7 @@ let
             options = "vers=${toString version}";
           }
         ];
+      networking.firewall.enable = false; # FIXME: only open statd
     };
 
 in
@@ -31,6 +32,7 @@ in
               /data 192.168.1.0/255.255.255.0(rw,no_root_squash,no_subtree_check,fsid=0)
             '';
           services.nfs.server.createMountPoints = true;
+          networking.firewall.enable = false; # FIXME: figure out what ports need to be allowed
         };
     };