summary refs log tree commit diff
path: root/nixos/tests/networking.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2017-02-02 22:21:03 +0100
committerProfpatsch <mail@profpatsch.de>2017-02-16 21:24:40 +0100
commit9debdaf512bc510f7f5d5450c4902e7d1f713274 (patch)
tree95047796efb8103b3192cd94a900b54235a9d4cc /nixos/tests/networking.nix
parent03024b39b7d4b94724faa1a62f21aed3531bb35a (diff)
downloadnixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar.gz
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar.bz2
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar.lz
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar.xz
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.tar.zst
nixlib-9debdaf512bc510f7f5d5450c4902e7d1f713274.zip
networking.bonds: add support for arbitrary driverOptions
Until now the four attributes available very selectively provided a small
subset, while copying upstream documentation.

We make driver options an arbitrary key-value set and point to kernel
documentation, which is always up-to-date. This way every option can be set.
The four already existing options are deprecated with a warning.
Diffstat (limited to 'nixos/tests/networking.nix')
-rw-r--r--nixos/tests/networking.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/networking.nix b/nixos/tests/networking.nix
index 83103f35d482..8b573869c157 100644
--- a/nixos/tests/networking.nix
+++ b/nixos/tests/networking.nix
@@ -236,8 +236,8 @@ let
           firewall.allowPing = true;
           useDHCP = false;
           bonds.bond = {
-            mode = "balance-rr";
             interfaces = [ "eth1" "eth2" ];
+            driverOptions.mode = "balance-rr";
           };
           interfaces.eth1.ip4 = mkOverride 0 [ ];
           interfaces.eth2.ip4 = mkOverride 0 [ ];