summary refs log tree commit diff
path: root/nixos/tests/ipv6.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-02-22 00:37:13 +0100
committerGitHub <noreply@github.com>2017-02-22 00:37:13 +0100
commit5b14e91717f78d0fbcf831f0501950cc9e71f9a6 (patch)
tree4bfb3501a7b21388a22255d51b31e1486ee56d05 /nixos/tests/ipv6.nix
parent2cd286b3cfb5b437c9057bb0413361f532f174ff (diff)
parent45719174c3a82af6e0df27812d51edc323ccc897 (diff)
downloadnixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar.gz
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar.bz2
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar.lz
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar.xz
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.tar.zst
nixlib-5b14e91717f78d0fbcf831f0501950cc9e71f9a6.zip
Merge pull request #22822 from Mic92/iputils
iputils: 20151218 -> 20161105
Diffstat (limited to 'nixos/tests/ipv6.nix')
-rw-r--r--nixos/tests/ipv6.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/tests/ipv6.nix b/nixos/tests/ipv6.nix
index 4e2e6379cad3..060f63216796 100644
--- a/nixos/tests/ipv6.nix
+++ b/nixos/tests/ipv6.nix
@@ -54,22 +54,22 @@ import ./make-test.nix ({ pkgs, ...} : {
       }
 
       subtest "loopback address", sub {
-          $client->succeed("ping6 -c 1 ::1 >&2");
-          $client->fail("ping6 -c 1 ::2 >&2");
+          $client->succeed("ping -c 1 ::1 >&2");
+          $client->fail("ping -c 1 ::2 >&2");
       };
 
       subtest "local link addressing", sub {
           my $clientIp = waitForAddress $client, "eth1", "link";
           my $serverIp = waitForAddress $server, "eth1", "link";
-          $client->succeed("ping6 -c 1 -I eth1 $clientIp >&2");
-          $client->succeed("ping6 -c 1 -I eth1 $serverIp >&2");
+          $client->succeed("ping -c 1 $clientIp%eth1 >&2");
+          $client->succeed("ping -c 1 $serverIp%eth1 >&2");
       };
 
       subtest "global addressing", sub {
           my $clientIp = waitForAddress $client, "eth1", "global";
           my $serverIp = waitForAddress $server, "eth1", "global";
-          $client->succeed("ping6 -c 1 $clientIp >&2");
-          $client->succeed("ping6 -c 1 $serverIp >&2");
+          $client->succeed("ping -c 1 $clientIp >&2");
+          $client->succeed("ping -c 1 $serverIp >&2");
           $client->succeed("curl --fail -g http://[$serverIp]");
           $client->fail("curl --fail -g http://[$clientIp]");
       };