summary refs log tree commit diff
path: root/nixos/tests/ipfs.nix
diff options
context:
space:
mode:
authorMaximilian Güntner <code@klandest.in>2016-11-26 20:07:01 +0100
committerMaximilian Güntner <code@klandest.in>2016-11-28 15:33:58 +0100
commitf7c099bd8c9c2ad89408f3b689c06daa7ae654ac (patch)
treeae460eed260f528abb043d15b54bf07e31a697c1 /nixos/tests/ipfs.nix
parent0526a5c90a251cf88f247af0dc436e9b08da733c (diff)
downloadnixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar.gz
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar.bz2
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar.lz
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar.xz
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.tar.zst
nixlib-f7c099bd8c9c2ad89408f3b689c06daa7ae654ac.zip
tests: added basic ipfs test
$getter can be used once ipfs supports private/local networks
and or internet gets routed to the VMs

Signed-off-by: Maximilian Güntner <code@klandest.in>
Diffstat (limited to 'nixos/tests/ipfs.nix')
-rw-r--r--nixos/tests/ipfs.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/nixos/tests/ipfs.nix b/nixos/tests/ipfs.nix
new file mode 100644
index 000000000000..92d742e4f37f
--- /dev/null
+++ b/nixos/tests/ipfs.nix
@@ -0,0 +1,37 @@
+
+import ./make-test.nix ({ pkgs, ...} : {
+  name = "ipfs";
+  meta = with pkgs.stdenv.lib.maintainers; {
+    maintainers = [ mguentner ];
+  };
+
+  nodes = {
+    adder =
+      { config, pkgs, ... }:
+      {
+        services.ipfs = {
+          enable = true;
+          gatewayAddress = "/ip4/127.0.0.1/tcp/2323";
+          apiAddress = "/ip4/127.0.0.1/tcp/2324";
+        };
+      };
+    getter =
+      { config, pkgs, ... }:
+      {
+         services.ipfs.enable = true;
+      };
+  };
+
+  testScript = ''
+    startAll;
+    $adder->waitForUnit("ipfs");
+    # * => needs ipfs dht (internet)
+    # $getter->waitForUnit("ipfs");
+    $adder->waitUntilSucceeds("ipfs --api /ip4/127.0.0.1/tcp/2324 id");
+    $adder->mustSucceed("([[ -n '$(ipfs --api /ip4/127.0.0.1/tcp/2324 config Addresses.gatewayAddress | grep /ip4/127.0.0.1/tcp/2323)' ]])");
+    # * $getter->waitUntilSucceeds("ipfs --api /ip4/127.0.0.1/tcp/5001 id");
+    # * my $ipfsHash = $adder->mustSucceed("echo fnord | ipfs --api /ip4/127.0.0.1/tcp/2324 add | cut -d' ' -f2");
+    $adder->mustSucceed("([[ -n '$(echo fnord | ipfs --api /ip4/127.0.0.1/tcp/2324 add | grep added)' ]])");
+    # * $getter->mustSucceed("ipfs --api /ip4/127.0.0.1/tcp/5001 cat $ipfsHash");
+    '';
+})