summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorobadz <obadz-git@obadz.com>2016-07-24 16:17:04 +0100
committerobadz <obadz-git@obadz.com>2016-08-09 17:01:42 +0100
commit74b3ad148d36f4e8b9a41a08cbf6e2407cdda425 (patch)
treedc91d7cf35631880959eea1f3ce1271dd25a7fa0 /nixos/tests/installer.nix
parentf8fad62c8e8ea4ec80a5836318fc5c87f0f9fee5 (diff)
downloadnixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar.gz
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar.bz2
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar.lz
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar.xz
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.tar.zst
nixlib-74b3ad148d36f4e8b9a41a08cbf6e2407cdda425.zip
nixos/tests/installer.nix: add libxml2 & libxslt to prevent download attempts
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix22
1 files changed, 12 insertions, 10 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index e71168a73660..1df2c651f9bc 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -201,19 +201,21 @@ let
 
             # The test cannot access the network, so any packages we
             # need must be included in the VM.
-            system.extraDependencies =
-              [ pkgs.sudo
-                pkgs.docbook5
-                pkgs.docbook5_xsl
-                pkgs.unionfs-fuse
-                pkgs.ntp
-                pkgs.nixos-artwork
-                pkgs.perlPackages.XMLLibXML
-                pkgs.perlPackages.ListCompare
+            system.extraDependencies = with pkgs;
+              [ sudo
+                libxml2.bin
+                libxslt.bin
+                docbook5
+                docbook5_xsl
+                unionfs-fuse
+                ntp
+                nixos-artwork
+                perlPackages.XMLLibXML
+                perlPackages.ListCompare
 
                 # add curl so that rather than seeing the test attempt to download
                 # curl's tarball, we see what it's trying to download
-                pkgs.curl
+                curl
               ]
               ++ optional (bootLoader == "grub" && grubVersion == 1) pkgs.grub
               ++ optionals (bootLoader == "grub" && grubVersion == 2) [ pkgs.grub2 pkgs.grub2_efi ];