summary refs log tree commit diff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2016-03-28 14:00:00 -0500
committerGraham Christensen <graham@grahamc.com>2016-03-28 14:00:00 -0500
commit37617a2c4522176b5ebd07909f3c8a24a2aaa8ff (patch)
tree340257d53f57b9217cf8093cc0bfe34bbac39196 /nixos/tests/installer.nix
parent9825a81cfc9eb368278383a0965a745f325b8038 (diff)
downloadnixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar.gz
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar.bz2
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar.lz
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar.xz
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.tar.zst
nixlib-37617a2c4522176b5ebd07909f3c8a24a2aaa8ff.zip
nixos.tests.installer.swraid: mdadm verbosity
These two steps seem to fail intermittently with exit code 1. It isn't clear to me why, or what the issue is. Adding the `--verbose` option, hoping to capture some debugging information which might aid stabilization. Also: I was unable to replicate the failure locally.
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 9e5a6ad04e1e..05c3f267eb93 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -366,8 +366,8 @@ in {
               "mkdir /mnt/boot",
               "mount LABEL=boot /mnt/boot",
               "udevadm settle",
-              "mdadm -W /dev/md0", # wait for sync to finish; booting off an unsynced device tends to fail
-              "mdadm -W /dev/md1",
+              "mdadm --verbose -W /dev/md0", # wait for sync to finish; booting off an unsynced device tends to fail
+              "mdadm --verbose -W /dev/md1",
           );
         '';
     };