summary refs log tree commit diff
path: root/nixos/tests/gjs.nix
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2018-02-14 22:19:56 +0100
committerJan Tojnar <jtojnar@gmail.com>2018-02-14 22:43:59 +0100
commit7713889556b013ef109c35be7fccb378a4f13b6d (patch)
tree0712d8a6df5a95cc871638f0aea0b788dc8fb7ed /nixos/tests/gjs.nix
parentb2238b7383ed9cc1c53494235116b32e841c2ea2 (diff)
downloadnixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar.gz
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar.bz2
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar.lz
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar.xz
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.tar.zst
nixlib-7713889556b013ef109c35be7fccb378a4f13b6d.zip
nixos/gjs: add test
Diffstat (limited to 'nixos/tests/gjs.nix')
-rw-r--r--nixos/tests/gjs.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nixos/tests/gjs.nix b/nixos/tests/gjs.nix
new file mode 100644
index 000000000000..e6002ef98dd0
--- /dev/null
+++ b/nixos/tests/gjs.nix
@@ -0,0 +1,19 @@
+# run installed tests
+import ./make-test.nix ({ pkgs, ... }: {
+  name = "gjs";
+
+  meta = {
+    maintainers = pkgs.gnome3.gjs.meta.maintainers;
+  };
+
+  machine = { pkgs, ... }: {
+    imports = [ ./common/x11.nix ];
+    environment.systemPackages = with pkgs; [ gnome-desktop-testing ];
+    environment.variables.XDG_DATA_DIRS = [ "${pkgs.gnome3.gjs.installedTests}/share" ];
+  };
+
+  testScript = ''
+    $machine->waitForX;
+    $machine->succeed("gnome-desktop-testing-runner");
+  '';
+})