summary refs log tree commit diff
path: root/nixos/tests/gdk-pixbuf.nix
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2018-04-25 18:35:33 +0200
committerJan Tojnar <jtojnar@gmail.com>2018-04-25 18:37:44 +0200
commitad589329e71cde816a7ec8f2779ff368ce51a622 (patch)
tree76dd22128d29a3ebfc4f137413314e16c2655535 /nixos/tests/gdk-pixbuf.nix
parent70a5ba0ac9b4f9a2bd73bafe954f2bc070ee14ad (diff)
downloadnixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar.gz
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar.bz2
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar.lz
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar.xz
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.tar.zst
nixlib-ad589329e71cde816a7ec8f2779ff368ce51a622.zip
nixos/release.nix: add tests.gdk-pixbuf
Diffstat (limited to 'nixos/tests/gdk-pixbuf.nix')
-rw-r--r--nixos/tests/gdk-pixbuf.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/nixos/tests/gdk-pixbuf.nix b/nixos/tests/gdk-pixbuf.nix
new file mode 100644
index 000000000000..b20f61b5ffe2
--- /dev/null
+++ b/nixos/tests/gdk-pixbuf.nix
@@ -0,0 +1,19 @@
+# run installed tests
+import ./make-test.nix ({ pkgs, ... }: {
+  name = "gdk-pixbuf";
+
+  meta = {
+    maintainers = pkgs.gdk_pixbuf.meta.maintainers;
+  };
+
+  machine = { pkgs, ... }: {
+    environment.systemPackages = with pkgs; [ gnome-desktop-testing ];
+    environment.variables.XDG_DATA_DIRS = [ "${pkgs.gdk_pixbuf.installedTests}/share" ];
+
+    virtualisation.memorySize = 4096; # Tests allocate a lot of memory trying to exploit a CVE
+  };
+
+  testScript = ''
+    $machine->succeed("gnome-desktop-testing-runner");
+  '';
+})