summary refs log tree commit diff
path: root/nixos/tests/ferm.nix
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2017-12-03 05:14:54 +0100
committerrnhmjoj <rnhmjoj@inventati.org>2018-02-17 14:57:07 +0100
commite239c1e5820bdbb3d94ccc46e2d6756b0d37057d (patch)
tree949c07008657835d1ac6d6b247a50d05d7152cae /nixos/tests/ferm.nix
parentc1bed05e341756f7fdfa73035c7f1e078e49be3d (diff)
downloadnixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.gz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.bz2
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.lz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.xz
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.tar.zst
nixlib-e239c1e5820bdbb3d94ccc46e2d6756b0d37057d.zip
nixos/tests: rename IP addresses/routes options
Diffstat (limited to 'nixos/tests/ferm.nix')
-rw-r--r--nixos/tests/ferm.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/tests/ferm.nix b/nixos/tests/ferm.nix
index 8f2a8c01eebc..bb7daae118c0 100644
--- a/nixos/tests/ferm.nix
+++ b/nixos/tests/ferm.nix
@@ -11,8 +11,8 @@ import ./make-test.nix ({ pkgs, ...} : {
         with pkgs.lib;
         {
           networking = {
-            interfaces.eth1.ip6 = mkOverride 0 [ { address = "fd00::2"; prefixLength = 64; } ];
-            interfaces.eth1.ip4 = mkOverride 0 [ { address = "192.168.1.2"; prefixLength = 24; } ];
+            interfaces.eth1.ipv6.addresses = mkOverride 0 [ { address = "fd00::2"; prefixLength = 64; } ];
+            interfaces.eth1.ipv4.addresses = mkOverride 0 [ { address = "192.168.1.2"; prefixLength = 24; } ];
           };
       };
       server =
@@ -20,8 +20,8 @@ import ./make-test.nix ({ pkgs, ...} : {
         with pkgs.lib;
         {
           networking = {
-            interfaces.eth1.ip6 = mkOverride 0 [ { address = "fd00::1"; prefixLength = 64; } ];
-            interfaces.eth1.ip4 = mkOverride 0 [ { address = "192.168.1.1"; prefixLength = 24; } ];
+            interfaces.eth1.ipv6.addresses = mkOverride 0 [ { address = "fd00::1"; prefixLength = 64; } ];
+            interfaces.eth1.ipv4.addresses = mkOverride 0 [ { address = "192.168.1.1"; prefixLength = 24; } ];
           };
 
           services = {