summary refs log tree commit diff
path: root/nixos/tests/ec2.nix
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2018-07-18 14:28:48 +0000
committervolth <volth@volth.com>2018-08-20 22:02:02 +0000
commit341250fa10e07f50a2700fe18465bb91900c851d (patch)
tree97be9d21102b087e2f06e1d459016e8499bc4b82 /nixos/tests/ec2.nix
parent27ecfd34e8b676438ae03be601bfca46c4f61b7a (diff)
downloadnixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar.gz
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar.bz2
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar.lz
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar.xz
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.tar.zst
nixlib-341250fa10e07f50a2700fe18465bb91900c851d.zip
qemu: 2.12.1 -> 3.0.0
Diffstat (limited to 'nixos/tests/ec2.nix')
-rw-r--r--nixos/tests/ec2.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/nixos/tests/ec2.nix b/nixos/tests/ec2.nix
index f585fa2ec237..8271747ccc63 100644
--- a/nixos/tests/ec2.nix
+++ b/nixos/tests/ec2.nix
@@ -68,7 +68,9 @@ let
           # again when it deletes link-local addresses.) Ideally we'd
           # turn off the DHCP server, but qemu does not have an option
           # to do that.
-          my $startCommand = "qemu-kvm -m 768 -net nic,vlan=0,model=virtio -net 'user,vlan=0,net=169.0.0.0/8,guestfwd=tcp:169.254.169.254:80-cmd:${pkgs.micro-httpd}/bin/micro_httpd ${metaData}'";
+          my $startCommand = "qemu-kvm -m 768";
+          $startCommand .= " -device virtio-net-pci,netdev=vlan0";
+          $startCommand .= " -netdev 'user,id=vlan0,net=169.0.0.0/8,guestfwd=tcp:169.254.169.254:80-cmd:${pkgs.micro-httpd}/bin/micro_httpd ${metaData}'";
           $startCommand .= " -drive file=$diskImage,if=virtio,werror=report";
           $startCommand .= " \$QEMU_OPTS";