summary refs log tree commit diff
path: root/nixos/tests/containers-ipv6.nix
diff options
context:
space:
mode:
authorArnold Krille <arnold@arnoldarts.de>2016-01-31 21:45:05 +0100
committerArnold Krille <arnold@arnoldarts.de>2016-04-02 17:07:41 +0200
commit3b31c52d4b2784de33280feb9949f2ab8241ac50 (patch)
tree04c3d5b62606e4a0edf6de437f4898b9d115d406 /nixos/tests/containers-ipv6.nix
parentaa46904490cadc55817ec32695c484026ddf3e15 (diff)
downloadnixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar.gz
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar.bz2
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar.lz
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar.xz
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.tar.zst
nixlib-3b31c52d4b2784de33280feb9949f2ab8241ac50.zip
containers: Add more tests for ipv6 and hostbridge
A testcase each for
- declarative ipv6-only container
  Seems odd to define the container IPs with their prefix length attached.
  There should be a better way…
- declarative bridged container

Also fix the ping test by waiting for the container to start

When the ping was executed, the container might not have finished starting. Or
the host-side of the container wasn't finished with config. Waiting for
2 seconds in between fixes this.
Diffstat (limited to 'nixos/tests/containers-ipv6.nix')
-rw-r--r--nixos/tests/containers-ipv6.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/nixos/tests/containers-ipv6.nix b/nixos/tests/containers-ipv6.nix
new file mode 100644
index 000000000000..0c1b8e88564d
--- /dev/null
+++ b/nixos/tests/containers-ipv6.nix
@@ -0,0 +1,61 @@
+# Test for NixOS' container support.
+
+let
+  hostIp = "fc00::2";
+  localIp = "fc00::1";
+in
+
+import ./make-test.nix ({ pkgs, ...} : {
+  name = "containers-ipv6";
+  meta = with pkgs.stdenv.lib.maintainers; {
+    maintainers = [ aristid aszlig eelco chaoflow ];
+  };
+
+  machine =
+    { config, pkgs, ... }:
+    { imports = [ ../modules/installer/cd-dvd/channel.nix ];
+      virtualisation.writableStore = true;
+      virtualisation.memorySize = 768;
+
+      containers.webserver =
+        { privateNetwork = true;
+          hostAddress6 = hostIp;
+          localAddress6 = localIp;
+          config =
+            { services.httpd.enable = true;
+              services.httpd.adminAddr = "foo@example.org";
+              networking.firewall.allowedTCPPorts = [ 80 ];
+              networking.firewall.allowPing = true;
+            };
+        };
+
+      virtualisation.pathsInNixDB = [ pkgs.stdenv ];
+    };
+
+  testScript =
+    ''
+      $machine->waitForUnit("default.target");
+      $machine->succeed("nixos-container list") =~ /webserver/ or die;
+
+      # Start the webserver container.
+      $machine->succeed("nixos-container start webserver");
+
+      # wait two seconds for the container to start and the network to be up
+      sleep 2;
+
+      # Since "start" returns after the container has reached
+      # multi-user.target, we should now be able to access it.
+      my $ip = "${localIp}";
+      chomp $ip;
+      $machine->succeed("ping6 -n -c 1 $ip");
+      $machine->succeed("curl --fail http://[$ip]/ > /dev/null");
+
+      # Stop the container.
+      $machine->succeed("nixos-container stop webserver");
+      $machine->fail("curl --fail --connect-timeout 2 http://[$ip]/ > /dev/null");
+
+      # Destroying a declarative container should fail.
+      $machine->fail("nixos-container destroy webserver");
+    '';
+
+})