summary refs log tree commit diff
path: root/nixos/tests/bittorrent.nix
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2018-02-19 14:12:58 +0000
committerGitHub <noreply@github.com>2018-02-19 14:12:58 +0000
commit10b3f7d3564d4ef1deeaed7ece130588d5ba1905 (patch)
tree5c551c6f5aa44f598d1bdc00ba23006fb65e13d4 /nixos/tests/bittorrent.nix
parente37b756b91a0713cefdf8a53d78feadcd00a40fc (diff)
parent06517547519737cd4c719b0c8ef78d046816f57e (diff)
downloadnixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar.gz
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar.bz2
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar.lz
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar.xz
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.tar.zst
nixlib-10b3f7d3564d4ef1deeaed7ece130588d5ba1905.zip
Merge pull request #27688 from rnhmjoj/routes
nixos/networking-interfaces: make static routes configurable
Diffstat (limited to 'nixos/tests/bittorrent.nix')
-rw-r--r--nixos/tests/bittorrent.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/tests/bittorrent.nix b/nixos/tests/bittorrent.nix
index 3a718a798315..50c98664660a 100644
--- a/nixos/tests/bittorrent.nix
+++ b/nixos/tests/bittorrent.nix
@@ -16,7 +16,7 @@ let
   miniupnpdConf = nodes: pkgs.writeText "miniupnpd.conf"
     ''
       ext_ifname=eth1
-      listening_ip=${(pkgs.lib.head nodes.router.config.networking.interfaces.eth2.ip4).address}/24
+      listening_ip=${(pkgs.lib.head nodes.router.config.networking.interfaces.eth2.ipv4.addresses).address}/24
       allow 1024-65535 192.168.2.0/24 1024-65535
     '';
 
@@ -56,7 +56,7 @@ in
         { environment.systemPackages = [ pkgs.transmission ];
           virtualisation.vlans = [ 2 ];
           networking.defaultGateway =
-            (pkgs.lib.head nodes.router.config.networking.interfaces.eth2.ip4).address;
+            (pkgs.lib.head nodes.router.config.networking.interfaces.eth2.ipv4.addresses).address;
           networking.firewall.enable = false;
         };
 
@@ -84,7 +84,7 @@ in
       # Create the torrent.
       $tracker->succeed("mkdir /tmp/data");
       $tracker->succeed("cp ${file} /tmp/data/test.tar.bz2");
-      $tracker->succeed("transmission-create /tmp/data/test.tar.bz2 -p -t http://${(pkgs.lib.head nodes.tracker.config.networking.interfaces.eth1.ip4).address}:6969/announce -o /tmp/test.torrent");
+      $tracker->succeed("transmission-create /tmp/data/test.tar.bz2 -p -t http://${(pkgs.lib.head nodes.tracker.config.networking.interfaces.eth1.ipv4.addresses).address}:6969/announce -o /tmp/test.torrent");
       $tracker->succeed("chmod 644 /tmp/test.torrent");
 
       # Start the tracker.  !!! use a less crappy tracker