summary refs log tree commit diff
path: root/nixos/tests/avahi.nix
diff options
context:
space:
mode:
authorJoel Moberg <joel.moberg@gmail.com>2016-02-28 16:03:47 +0100
committerJoel Moberg <joel.moberg@gmail.com>2016-02-28 16:18:39 +0100
commit75e96d2c30cf0a138e98d5611aa80465d92d9e43 (patch)
tree013e37e3e54d7b1d142d5966b8438e2a043c3f08 /nixos/tests/avahi.nix
parent40c586b7ce2c559374df435f46d673baf711c543 (diff)
downloadnixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar.gz
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar.bz2
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar.lz
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar.xz
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.tar.zst
nixlib-75e96d2c30cf0a138e98d5611aa80465d92d9e43.zip
avahi: fix test
Reflects module changes made by cdd7310a503481e3c40266be45b6b8256d95ecbd
Diffstat (limited to 'nixos/tests/avahi.nix')
-rw-r--r--nixos/tests/avahi.nix25
1 files changed, 14 insertions, 11 deletions
diff --git a/nixos/tests/avahi.nix b/nixos/tests/avahi.nix
index a8369a6d1f88..976a770e887c 100644
--- a/nixos/tests/avahi.nix
+++ b/nixos/tests/avahi.nix
@@ -5,18 +5,21 @@ import ./make-test.nix ({ pkgs, ... } : {
     maintainers = [ eelco chaoflow ];
   };
 
-  nodes = {
-    one =
-      { config, pkgs, ... }: {
-        services.avahi.enable = true;
-        services.avahi.nssmdns = true;
-      };
-
-    two =
-      { config, pkgs, ... }: {
-        services.avahi.enable = true;
-        services.avahi.nssmdns = true;
+  nodes = let
+    cfg = { config, pkgs, ... }: {
+      services.avahi = {
+        enable = true;
+        nssmdns = true;
+        publish.addresses = true;
+        publish.domain = true;
+        publish.enable = true;
+        publish.userServices = true;
+        publish.workstation = true;
       };
+    };
+  in {
+    one = cfg;
+    two = cfg;
   };
 
   testScript =