summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-06-10 13:14:40 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-06-10 15:28:56 +0200
commitd906939e74b79318b4493c2085bcfe3f7dd92bb7 (patch)
tree9ebe21fd5c83c121898ee70e12194d43315913f6 /nixos/release.nix
parente5db79a8597873472c49d18061f6fd9e6f3e7437 (diff)
downloadnixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar.gz
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar.bz2
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar.lz
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar.xz
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.tar.zst
nixlib-d906939e74b79318b4493c2085bcfe3f7dd92bb7.zip
Installer tests: Don't use the ISO
We already have separate tests for checking whether the ISO boots
correctly, so it's not necessary to do that here. So now
tests/installer.nix just tests nixos-install, from a regular NixOS VM
that uses the host's Nix store. This makes running the tests more
convenient because we don't have to build a new ISO after every
change.
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix1
1 files changed, 0 insertions, 1 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 3559926eefad..51a58da4454d 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -256,7 +256,6 @@ in rec {
   tests.installer.grub1 = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).grub1.test);
   tests.installer.lvm = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).lvm.test);
   tests.installer.luksroot = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).luksroot.test);
-  tests.installer.rebuildCD = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).rebuildCD.test);
   tests.installer.separateBoot = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).separateBoot.test);
   tests.installer.simple = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).simple.test);
   tests.installer.simpleLabels = forAllSystems (system: hydraJob (import tests/installer.nix { inherit system; }).simpleLabels.test);