summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2016-03-02 02:18:35 +0100
committeraszlig <aszlig@redmoonstudios.org>2016-03-02 02:18:35 +0100
commita429444a75f0ece433b6653b2f82a4876f8b07c8 (patch)
treea2db85bf45674a3f29fda04d7f8535ade623759c /nixos/release.nix
parent4686bc54a61e332129574adf4a1063937a66e4ac (diff)
downloadnixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar.gz
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar.bz2
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar.lz
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar.xz
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.tar.zst
nixlib-a429444a75f0ece433b6653b2f82a4876f8b07c8.zip
nixos/release: Replace a: b: a // b by mergeAttrs
No change in functionality, it just looks nicer that way.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index fb74766e67c6..069cf3727de7 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -31,7 +31,7 @@ let
   # If the test is only for a particular system, use only the specified
   # system instead of generating attributes for all available systems.
   in if args ? system then discover (import fn args)
-     else foldAttrs (a: b: a // b) {} (map discoverForSystem supportedSystems);
+     else foldAttrs mergeAttrs {} (map discoverForSystem supportedSystems);
 
   pkgs = import nixpkgs { system = "x86_64-linux"; };