summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorTim Steinbach <NeQuissimus@users.noreply.github.com>2017-09-06 15:04:10 -0400
committerGitHub <noreply@github.com>2017-09-06 15:04:10 -0400
commit7faad2dce829d7db50dbfe3a6466e79c6022e7e6 (patch)
tree639de03e823b028fe918835b878858c809324ad9 /nixos/release.nix
parenta54b2e3ba226c9fa3e7f4ec72fbada8e0859a300 (diff)
parentb4ccef2163d07e5f35bc802c357d2d2167409a3a (diff)
downloadnixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar.gz
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar.bz2
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar.lz
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar.xz
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.tar.zst
nixlib-7faad2dce829d7db50dbfe3a6466e79c6022e7e6.zip
Merge pull request #29040 from NeQuissimus/tests_sys
More basic system tests
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 9681194c1c45..a893a64df1c2 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -241,6 +241,7 @@ in rec {
   tests.ec2-nixops = hydraJob (import tests/ec2.nix { system = "x86_64-linux"; }).boot-ec2-nixops;
   tests.ec2-config = hydraJob (import tests/ec2.nix { system = "x86_64-linux"; }).boot-ec2-config;
   tests.elk = callTest tests/elk.nix {};
+  tests.env = callTest tests/env.nix {};
   tests.ferm = callTest tests/ferm.nix {};
   tests.firefox = callTest tests/firefox.nix {};
   tests.firewall = callTest tests/firewall.nix {};
@@ -265,6 +266,7 @@ in rec {
   tests.kernel-copperhead = tests/kernel-copperhead.nix {};
   tests.kernel-latest = tests/kernel-latest.nix {};
   tests.kernel-lts = tests/kernel-lts.nix {};
+  tests.kernel-params = tests/kernel-params.nix {};
   tests.keystone = callTest tests/keystone.nix {};
   tests.kubernetes = hydraJob (import tests/kubernetes.nix { system = "x86_64-linux"; });
   tests.latestKernel.login = callTest tests/login.nix { latestKernel = true; };
@@ -310,6 +312,7 @@ in rec {
   tests.slim = callTest tests/slim.nix {};
   tests.smokeping = callTest tests/smokeping.nix {};
   tests.snapper = callTest tests/snapper.nix {};
+  tests.sysctl = callTest tests/sysctl.nix {};
   tests.taskserver = callTest tests/taskserver.nix {};
   tests.tomcat = callTest tests/tomcat.nix {};
   tests.udisks2 = callTest tests/udisks2.nix {};