summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-12-13 11:15:48 +0100
committeraszlig <aszlig@redmoonstudios.org>2014-12-13 11:43:44 +0100
commit69858d7743293d8f94b3d3160c9c3401722e4c10 (patch)
tree34a7c50ca27d9afa973e45c647b4f200dcb6c334 /nixos/release.nix
parent34b0d860d59663ac5914d087d0a5dcfd872a1334 (diff)
downloadnixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar.gz
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar.bz2
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar.lz
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar.xz
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.tar.zst
nixlib-69858d7743293d8f94b3d3160c9c3401722e4c10.zip
nixos: Add VM test for VirtualBox.
Currently it pretty much tests starting up virtual machines and just
shutting down afterwards, but for both VBoxManage and the VirtualBox
GUI.

This helps catching errors in hardened mode, however we still need to
test whether networking works the way intended (and I fear that this is
broken at the moment).

The VirtualBox VM is _not_ using hardware virtualization support (thus
we use system = "i686-linux", because x86_64 has no emulation support),
because we're already within a qemu VM, which means it's going to be
slow as hell (that's why I've written own subs just for testing
startup/shutdown/whatnot with respective timeouts).

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 12dd81f89707..0694c52a4300 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -306,6 +306,7 @@ in rec {
   tests.simple = callTest tests/simple.nix {};
   tests.tomcat = callTest tests/tomcat.nix {};
   tests.udisks2 = callTest tests/udisks2.nix {};
+  tests.virtualbox = callTest tests/virtualbox.nix {};
   tests.xfce = callTest tests/xfce.nix {};