summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:23:38 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-14 14:23:38 +0200
commit36c05d5e5b0025c9c6f62b101478e5e9f6da8d91 (patch)
tree50c8aad7100545e31850c12d72e780f82a4b3f37 /nixos/release.nix
parentabe218950c779fd1c98034356d3b324d66a0d30a (diff)
downloadnixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar.gz
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar.bz2
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar.lz
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar.xz
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.tar.zst
nixlib-36c05d5e5b0025c9c6f62b101478e5e9f6da8d91.zip
Simplify running tests even further
Now you can just say:

  $ nix-build '<nixos/tests/login.nix>'

You can still get the driver script for interactive testing:

  $ nix-build '<nixos/tests/login.nix>' -A driver
  $ ./result/bin/nixos-test-driver
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 7465488ae167..45c37570c1ba 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -14,7 +14,7 @@ let
 
   forAllSystems = pkgs.lib.genAttrs systems;
 
-  callTest = fn: args: forAllSystems (system: (import fn ({ inherit system; } // args)).result);
+  callTest = fn: args: forAllSystems (system: import fn ({ inherit system; } // args));
 
   pkgs = import nixpkgs { system = "x86_64-linux"; };