summary refs log tree commit diff
path: root/nixos/release.nix
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-19 21:29:48 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-03-19 21:32:28 -0400
commit192f4144b282a7f04695fcb79d84e8278ee6af8c (patch)
treeac712ec83329e74f20d29a355f078fe14cbe4704 /nixos/release.nix
parente547bd0dc419cdbe2e8d8440224b252f723590ab (diff)
downloadnixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar.gz
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar.bz2
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar.lz
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar.xz
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.tar.zst
nixlib-192f4144b282a7f04695fcb79d84e8278ee6af8c.zip
release-lib: Filter supportedSystems with `meta.platforms`-style patterns
Instead of intersecting system strings, we filter with the sort of
patterns used in `meta.platforms`.

Indicating this change `forTheseSystems` has been renamed to
`forMatchingSystems`, since the given list is now patterns to match, and
not the systems themselves. [Just as with `meta.platforms`, systems
strings are also supported for backwards compatibility.]

This is more flexible, and makes the `forMatchingSystems` and
packagePlatforms` cases more analogous.
Diffstat (limited to 'nixos/release.nix')
-rw-r--r--nixos/release.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/release.nix b/nixos/release.nix
index 1db2da511441..a7d373d1f7cd 100644
--- a/nixos/release.nix
+++ b/nixos/release.nix
@@ -16,7 +16,7 @@ let
     inherit system;
   } // args);
 
-  callTestOnTheseSystems = systems: fn: args: forTheseSystems systems (system: hydraJob (importTest fn args system));
+  callTestOnTheseSystems = systems: fn: args: forMatchingSystems systems (system: hydraJob (importTest fn args system));
   callTest = callTestOnTheseSystems supportedSystems;
 
   callSubTests = callSubTestsOnTheseSystems supportedSystems;
@@ -123,7 +123,7 @@ in rec {
   # Build the initial ramdisk so Hydra can keep track of its size over time.
   initialRamdisk = buildFromConfig ({ pkgs, ... }: { }) (config: config.system.build.initialRamdisk);
 
-  netboot = forTheseSystems [ "x86_64-linux" "aarch64-linux" ] (system: makeNetboot {
+  netboot = forMatchingSystems [ "x86_64-linux" "aarch64-linux" ] (system: makeNetboot {
     inherit system;
     modules = [
       ./modules/installer/netboot/netboot-minimal.nix
@@ -137,7 +137,7 @@ in rec {
     inherit system;
   });
 
-  iso_graphical = forTheseSystems [ "x86_64-linux" ] (system: makeIso {
+  iso_graphical = forMatchingSystems [ "x86_64-linux" ] (system: makeIso {
     module = ./modules/installer/cd-dvd/installation-cd-graphical-kde.nix;
     type = "graphical";
     inherit system;
@@ -145,7 +145,7 @@ in rec {
 
   # A variant with a more recent (but possibly less stable) kernel
   # that might support more hardware.
-  iso_minimal_new_kernel = forTheseSystems [ "x86_64-linux" ] (system: makeIso {
+  iso_minimal_new_kernel = forMatchingSystems [ "x86_64-linux" ] (system: makeIso {
     module = ./modules/installer/cd-dvd/installation-cd-minimal-new-kernel.nix;
     type = "minimal-new-kernel";
     inherit system;
@@ -153,7 +153,7 @@ in rec {
 
 
   # A bootable VirtualBox virtual appliance as an OVA file (i.e. packaged OVF).
-  ova = forTheseSystems [ "x86_64-linux" ] (system:
+  ova = forMatchingSystems [ "x86_64-linux" ] (system:
 
     with import nixpkgs { inherit system; };