summary refs log tree commit diff
path: root/nixos/modules/virtualisation/qemu-vm.nix
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-04-22 10:42:31 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-04-22 10:42:31 +0300
commitd0c127487fd607c9c66cb0a1a4d1eb9782632ae1 (patch)
treef9c5b03739d8035469f50bcc17077fc581872967 /nixos/modules/virtualisation/qemu-vm.nix
parent01854a850a7e62c6a4f1de7c4ca0f1c9d89841c8 (diff)
downloadnixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar.gz
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar.bz2
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar.lz
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar.xz
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.tar.zst
nixlib-d0c127487fd607c9c66cb0a1a4d1eb9782632ae1.zip
qemu-img: Fix module paths
They are compressed nowadays.

Not sure if these are really needed since nobody noticed they were
broken, but anyway...
Diffstat (limited to 'nixos/modules/virtualisation/qemu-vm.nix')
-rw-r--r--nixos/modules/virtualisation/qemu-vm.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/virtualisation/qemu-vm.nix b/nixos/modules/virtualisation/qemu-vm.nix
index 7269fae51945..d9b866d2e55e 100644
--- a/nixos/modules/virtualisation/qemu-vm.nix
+++ b/nixos/modules/virtualisation/qemu-vm.nix
@@ -149,11 +149,11 @@ let
           ${pkgs.mtools}/bin/mlabel -i /dev/vda2 ::boot
 
           # Mount /boot; load necessary modules first.
-          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/nls/nls_cp437.ko || true
-          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/nls/nls_iso8859-1.ko || true
-          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/fat/fat.ko || true
-          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/fat/vfat.ko || true
-          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/efivarfs/efivarfs.ko || true
+          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/nls/nls_cp437.ko.xz || true
+          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/nls/nls_iso8859-1.ko.xz || true
+          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/fat/fat.ko.xz || true
+          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/fat/vfat.ko.xz || true
+          ${pkgs.kmod}/sbin/insmod ${pkgs.linux}/lib/modules/*/kernel/fs/efivarfs/efivarfs.ko.xz || true
           mkdir /boot
           mount /dev/vda2 /boot