summary refs log tree commit diff
path: root/nixos/modules/virtualisation/qemu-vm.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2016-12-29 21:23:21 +0100
committerEelco Dolstra <edolstra@gmail.com>2016-12-29 21:26:16 +0100
commitbbd03e236a58e9344c91861513699e070186a3c5 (patch)
tree8555efc63476d7ec9c1d19febb43b47b214e4ed1 /nixos/modules/virtualisation/qemu-vm.nix
parent87d5e27a3da0dfc4c791d319f365c48f4d472558 (diff)
downloadnixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar.gz
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar.bz2
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar.lz
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar.xz
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.tar.zst
nixlib-bbd03e236a58e9344c91861513699e070186a3c5.zip
Use looser 9pfs caching in VM tests/builds
This can give significant speed ups, see
https://github.com/edolstra/linux/commit/7e20254412c780a2102761fee92cb1d32ceeaefd.
Diffstat (limited to 'nixos/modules/virtualisation/qemu-vm.nix')
-rw-r--r--nixos/modules/virtualisation/qemu-vm.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/virtualisation/qemu-vm.nix b/nixos/modules/virtualisation/qemu-vm.nix
index 041c7dbec702..586f5d9c0a38 100644
--- a/nixos/modules/virtualisation/qemu-vm.nix
+++ b/nixos/modules/virtualisation/qemu-vm.nix
@@ -440,13 +440,13 @@ in
         ${if cfg.writableStore then "/nix/.ro-store" else "/nix/store"} =
           { device = "store";
             fsType = "9p";
-            options = [ "trans=virtio" "version=9p2000.L" "cache=loose" ];
+            options = [ "trans=virtio" "version=9p2000.L" "veryloose" ];
             neededForBoot = true;
           };
         "/tmp/xchg" =
           { device = "xchg";
             fsType = "9p";
-            options = [ "trans=virtio" "version=9p2000.L" "cache=loose" ];
+            options = [ "trans=virtio" "version=9p2000.L" "veryloose" ];
             neededForBoot = true;
           };
         "/tmp/shared" =