summary refs log tree commit diff
path: root/nixos/modules/virtualisation/qemu-vm.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-05-25 13:23:32 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-05-25 18:04:21 +0200
commit845c9b50bf7137c3e21f443e70ebcb16510f4e68 (patch)
tree0eddfbc8f8cf4140c392a1765966d543db3a8f6d /nixos/modules/virtualisation/qemu-vm.nix
parentbf2aaeb0f670d845821c9d50726b2cbf4a70e4e9 (diff)
downloadnixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar.gz
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar.bz2
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar.lz
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar.xz
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.tar.zst
nixlib-845c9b50bf7137c3e21f443e70ebcb16510f4e68.zip
boot.initrd.luks.devices: Change into an attribute set
This allows setting options for the same LUKS device in different
modules. For example, the auto-generated hardware-configuration.nix
can contain

  boot.initrd.luks.devices.crypted.device = "/dev/disk/...";

while configuration.nix can add

  boot.initrd.luks.devices.crypted.allowDiscards = true;

Also updated the examples/docs to use /disk/disk/by-uuid instead of
/dev/sda, since we shouldn't promote the use of the latter.
Diffstat (limited to 'nixos/modules/virtualisation/qemu-vm.nix')
-rw-r--r--nixos/modules/virtualisation/qemu-vm.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/virtualisation/qemu-vm.nix b/nixos/modules/virtualisation/qemu-vm.nix
index 8aa643687557..9d9b725a805d 100644
--- a/nixos/modules/virtualisation/qemu-vm.nix
+++ b/nixos/modules/virtualisation/qemu-vm.nix
@@ -465,7 +465,7 @@ in
       });
 
     swapDevices = mkVMOverride [ ];
-    boot.initrd.luks.devices = mkVMOverride [];
+    boot.initrd.luks.devices = mkVMOverride {};
 
     # Don't run ntpd in the guest.  It should get the correct time from KVM.
     services.ntp.enable = false;