summary refs log tree commit diff
path: root/nixos/modules/virtualisation/parallels-guest.nix
diff options
context:
space:
mode:
authorLuke Adams <luke.adams@belljar.io>2017-07-19 14:36:24 -0500
committerLuke Adams <luke.adams@belljar.io>2017-11-11 17:05:08 -0600
commit0f047e612bbdee78fae3ea85a6f0eb46428737e3 (patch)
treef9b9d38a10a338cd2f866472df0e0bafb1f4e6f2 /nixos/modules/virtualisation/parallels-guest.nix
parent6ead149ff91220706c0a347468925a2a288ca829 (diff)
downloadnixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar.gz
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar.bz2
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar.lz
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar.xz
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.tar.zst
nixlib-0f047e612bbdee78fae3ea85a6f0eb46428737e3.zip
prl-tools: Add all user services using systemd.user
Diffstat (limited to 'nixos/modules/virtualisation/parallels-guest.nix')
-rw-r--r--nixos/modules/virtualisation/parallels-guest.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/nixos/modules/virtualisation/parallels-guest.nix b/nixos/modules/virtualisation/parallels-guest.nix
index f27ee46f4894..604ba2e76ef4 100644
--- a/nixos/modules/virtualisation/parallels-guest.nix
+++ b/nixos/modules/virtualisation/parallels-guest.nix
@@ -89,5 +89,58 @@ in
       };
     };
 
+    systemd.services.prlcc = {
+      description = "Parallels Control Center";
+      wantedBy = [ "graphical.target" ];
+      serviceConfig = {
+        ExecStart = "${prl-tools}/bin/prlcc";
+      };
+    };
+  
+    systemd.user.services = {
+      prlcc = {
+        description = "Parallels Control Center";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prlcc";
+        };
+      };
+      prldnd = {
+        description = "Parallels Control Center";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prldnd";
+        };
+      };
+      prl_wmouse_d  = {
+        description = "Parallels Walking Mouse Daemon";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prl_wmouse_d";
+        };
+      };
+      prlcp = {
+        description = "Parallels CopyPaste Tool";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prlcp";
+        };
+      };
+      prlsga = {
+        description = "Parallels Shared Guest Applications Tool";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prlsga";
+        };
+      };
+      prlshprof = {
+        description = "Parallels Shared Profile Tool";
+        wantedBy = [ "graphical-session.target" ];
+        serviceConfig = {
+          ExecStart = "${prl-tools}/bin/prlshprof";
+        };
+      };
+    };
+
   };
 }