summary refs log tree commit diff
path: root/nixos/modules/virtualisation/openvswitch.nix
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2015-08-29 18:21:43 +0200
committerJaka Hudoklin <jakahudoklin@gmail.com>2015-08-29 18:21:43 +0200
commit29c0262708a6524f9de0cd96fa7b8df12891ea00 (patch)
tree9de6ca5b22d91bbae33ad2cc776d79dac985557e /nixos/modules/virtualisation/openvswitch.nix
parent46203a790da3d4953f7830c281441a84aa4916ee (diff)
downloadnixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar.gz
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar.bz2
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar.lz
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar.xz
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.tar.zst
nixlib-29c0262708a6524f9de0cd96fa7b8df12891ea00.zip
openvswitch service: fix ipsec startup order
Diffstat (limited to 'nixos/modules/virtualisation/openvswitch.nix')
-rw-r--r--nixos/modules/virtualisation/openvswitch.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/virtualisation/openvswitch.nix b/nixos/modules/virtualisation/openvswitch.nix
index 69ca13a71479..b5155246fdad 100644
--- a/nixos/modules/virtualisation/openvswitch.nix
+++ b/nixos/modules/virtualisation/openvswitch.nix
@@ -67,7 +67,6 @@ in {
       description = "Open_vSwitch Database Server";
       wantedBy = [ "multi-user.target" ];
       after = [ "systemd-udev-settle.service" ];
-      wants = [ "vswitchd.service" ];
       path = [ cfg.package ];
       restartTriggers = [ db cfg.package ];
       # Create the config database
@@ -108,6 +107,7 @@ in {
 
     systemd.services.vswitchd = {
       description = "Open_vSwitch Daemon";
+      wantedBy = [ "multi-user.target" ];
       bindsTo = [ "ovsdb.service" ];
       after = [ "ovsdb.service" ];
       path = [ cfg.package ];
@@ -135,8 +135,8 @@ in {
     systemd.services.ovs-monitor-ipsec = {
       description = "Open_vSwitch Ipsec Daemon";
       wantedBy = [ "multi-user.target" ];
-      requires = [ "racoon.service" ];
-      after = [ "vswitchd.service" ];
+      requires = [ "ovsdb.service" ];
+      before = [ "vswitchd.service" "racoon.service" ];
       environment.UNIXCTLPATH = "/tmp/ovsdb.ctl.sock";
       serviceConfig = {
         ExecStart = ''