summary refs log tree commit diff
path: root/nixos/modules/virtualisation/hyperv-guest.nix
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2017-10-14 14:42:12 +0800
committerPeter Hoeg <peter@hoeg.com>2017-10-14 14:42:49 +0800
commitb366760cf5992fce214abc336aa35c92160e48a5 (patch)
tree06d0be9e70a7bb2b8e86943300d6ad688f5b6be9 /nixos/modules/virtualisation/hyperv-guest.nix
parent6fd4209594f58bf79bf99aae42125101f9387f15 (diff)
downloadnixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar.gz
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar.bz2
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar.lz
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar.xz
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.tar.zst
nixlib-b366760cf5992fce214abc336aa35c92160e48a5.zip
Revert "hyperv-daemons: add nixos module"
This reverts commit 0944d44f1b040856e420aad815a0d1b62194a2cb.
Diffstat (limited to 'nixos/modules/virtualisation/hyperv-guest.nix')
-rw-r--r--nixos/modules/virtualisation/hyperv-guest.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/nixos/modules/virtualisation/hyperv-guest.nix b/nixos/modules/virtualisation/hyperv-guest.nix
deleted file mode 100644
index ecd2a8117710..000000000000
--- a/nixos/modules/virtualisation/hyperv-guest.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-let
-  cfg = config.virtualisation.hypervGuest;
-
-in {
-  options = {
-    virtualisation.hypervGuest = {
-      enable = mkEnableOption "Hyper-V Guest Support";
-    };
-  };
-
-  config = mkIf cfg.enable {
-    environment.systemPackages = [ config.boot.kernelPackages.hyperv-daemons.bin ];
-
-    security.rngd.enable = false;
-
-    # enable hotadding memory
-    services.udev.packages = lib.singleton (pkgs.writeTextFile {
-      name = "hyperv-memory-hotadd-udev-rules";
-      destination = "/etc/udev/rules.d/99-hyperv-memory-hotadd.rules";
-      text = ''
-        ACTION="add", SUBSYSTEM=="memory", ATTR{state}="online"
-      '';
-    });
-
-    systemd = {
-      packages = [ config.boot.kernelPackages.hyperv-daemons.lib ];
-
-      targets.hyperv-daemons = {
-        wantedBy = [ "multi-user.target" ];
-      };
-    };
-  };
-}