summary refs log tree commit diff
path: root/nixos/modules/virtualisation/google-compute-image.nix
diff options
context:
space:
mode:
authorRob Vermaas <rob.vermaas@gmail.com>2015-02-27 10:48:15 +0000
committerRob Vermaas <rob.vermaas@gmail.com>2015-02-27 10:48:15 +0000
commit24e05654072663d0a74349c450d6f5ff80445c39 (patch)
tree15b659160f83a2ad46725206bb94642f8c227cc9 /nixos/modules/virtualisation/google-compute-image.nix
parent836b3d835e92b542f0e5079d7742646de7d42751 (diff)
downloadnixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar.gz
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar.bz2
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar.lz
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar.xz
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.tar.zst
nixlib-24e05654072663d0a74349c450d6f5ff80445c39.zip
Only start fetch-keys for GCE image after ip-up.
Diffstat (limited to 'nixos/modules/virtualisation/google-compute-image.nix')
-rw-r--r--nixos/modules/virtualisation/google-compute-image.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/virtualisation/google-compute-image.nix b/nixos/modules/virtualisation/google-compute-image.nix
index f4f517a9600e..98985d2d2c57 100644
--- a/nixos/modules/virtualisation/google-compute-image.nix
+++ b/nixos/modules/virtualisation/google-compute-image.nix
@@ -129,10 +129,10 @@ in
 
       wantedBy = [ "sshd.service" ];
       before = [ "sshd.service" ];
-      after = [ "network-online.target" ];
-      wants = [ "network-online.target" ];
+      after = [ "network-online.target" "ip-up.target" ];
+      wants = [ "network-online.target" "ip-up.target" ];
 
-      script = let wget = "${pkgs.wget}/bin/wget --retry-connrefused -t 6 --waitretry=10 --header='Metadata-Flavor: Google'"; in
+      script = let wget = "${pkgs.wget}/bin/wget --retry-connrefused -t 15 --waitretry=10 --header='Metadata-Flavor: Google'"; in
         ''
           # When dealing with cryptographic keys, we want to keep things private.
           umask 077