summary refs log tree commit diff
path: root/nixos/modules/virtualisation/google-compute-image.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@higgsboson.tk>2016-12-14 23:49:14 +0100
committerJörg Thalheim <joerg@higgsboson.tk>2016-12-17 00:00:45 +0100
commit1590461887333e2fda46f4bd74aef3785b253089 (patch)
treecd5d6652a758dc54bffd73e9d313ba5d1d73abf1 /nixos/modules/virtualisation/google-compute-image.nix
parent993cbf8acb9da679bb8bca00eacada6d83ed6994 (diff)
downloadnixlib-1590461887333e2fda46f4bd74aef3785b253089.tar
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.gz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.bz2
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.lz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.xz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.zst
nixlib-1590461887333e2fda46f4bd74aef3785b253089.zip
ntp: make timesyncd the new default
- most nixos user only require time synchronisation,
  while ntpd implements a battery-included ntp server (1,215 LOCs of C-Code vs 64,302)
- timesyncd support ntp server per interface (if configured through dhcp for instance)
- timesyncd is already included in the systemd package, switching to it would
  save a little disk space (1,5M)
Diffstat (limited to 'nixos/modules/virtualisation/google-compute-image.nix')
-rw-r--r--nixos/modules/virtualisation/google-compute-image.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/virtualisation/google-compute-image.nix b/nixos/modules/virtualisation/google-compute-image.nix
index 90dbd3b6d632..0e6825c3f5da 100644
--- a/nixos/modules/virtualisation/google-compute-image.nix
+++ b/nixos/modules/virtualisation/google-compute-image.nix
@@ -125,7 +125,7 @@ in
     169.254.169.254 metadata.google.internal metadata
   '';
 
-  services.ntp.servers = [ "metadata.google.internal" ];
+  networking.timeServers = [ "metadata.google.internal" ];
 
   networking.usePredictableInterfaceNames = false;