summary refs log tree commit diff
path: root/nixos/modules/virtualisation/docker.nix
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2015-10-04 14:31:16 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-10-04 14:31:16 +0200
commit424e6e501a44dc38c610f6d2039dda1cfafe9490 (patch)
tree2c6609335ebc1e1d3ffefe6b18533b62f43d4d2c /nixos/modules/virtualisation/docker.nix
parent1d3a4b17dd687bc92843b0302bf98069bebf5fe6 (diff)
downloadnixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar.gz
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar.bz2
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar.lz
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar.xz
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.tar.zst
nixlib-424e6e501a44dc38c610f6d2039dda1cfafe9490.zip
nixos/modules: simplify pkgs.zfs handling
Thanks, @lethalman.
Diffstat (limited to 'nixos/modules/virtualisation/docker.nix')
-rw-r--r--nixos/modules/virtualisation/docker.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos/modules/virtualisation/docker.nix b/nixos/modules/virtualisation/docker.nix
index 0e1b9206999b..7288cf29875b 100644
--- a/nixos/modules/virtualisation/docker.nix
+++ b/nixos/modules/virtualisation/docker.nix
@@ -129,8 +129,7 @@ in
           LimitNPROC = 1048576;
         } // proxy_env;
 
-        path = [ pkgs.kmod ] ++
-          (if cfg.storageDriver == "zfs" then [ pkgs.zfs ] else []);
+        path = [ pkgs.kmod ] ++ (optional (cfg.storageDriver == "zfs") pkgs.zfs);
         environment.MODULE_DIR = "/run/current-system/kernel-modules/lib/modules";
 
         postStart = cfg.postStart;