summary refs log tree commit diff
path: root/nixos/modules/virtualisation/docker.nix
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2014-11-23 01:27:04 +0100
committerJaka Hudoklin <jakahudoklin@gmail.com>2014-11-29 02:27:17 +0100
commit2b261c1edf4c1e46489b054e334013a71a25990f (patch)
tree493490142e3b9c5183f1c1955be5148e4b48ef5d /nixos/modules/virtualisation/docker.nix
parent650226e3c433d9db439ad57e9dc52d2077aaea46 (diff)
downloadnixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar.gz
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar.bz2
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar.lz
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar.xz
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.tar.zst
nixlib-2b261c1edf4c1e46489b054e334013a71a25990f.zip
nixos: add kubernetes module
Diffstat (limited to 'nixos/modules/virtualisation/docker.nix')
-rw-r--r--nixos/modules/virtualisation/docker.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/modules/virtualisation/docker.nix b/nixos/modules/virtualisation/docker.nix
index 11d3f576728f..9ae9624fd481 100644
--- a/nixos/modules/virtualisation/docker.nix
+++ b/nixos/modules/virtualisation/docker.nix
@@ -103,6 +103,12 @@ in
           LimitNPROC = 1048576;
         } // proxy_env;
 
+        postStart = ''
+          while ! [ -e /var/run/docker.sock ]; do
+            sleep 0.1
+          done
+        '';
+
         # Presumably some containers are running we don't want to interrupt
         restartIfChanged = false;
       };