summary refs log tree commit diff
path: root/nixos/modules/virtualisation/docker-image.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2014-11-04 05:19:07 +0100
committeraszlig <aszlig@redmoonstudios.org>2014-11-04 05:19:07 +0100
commit8e516de3e76ce489271161b7fd8291edfb0adf40 (patch)
tree448df825db179e06ef9f730dfafbbfee71314e56 /nixos/modules/virtualisation/docker-image.nix
parent0f26e580bb87d377cc535a6a0c99fa50efa8f1c1 (diff)
downloadnixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar.gz
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar.bz2
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar.lz
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar.xz
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.tar.zst
nixlib-8e516de3e76ce489271161b7fd8291edfb0adf40.zip
nixos: Fix priorities of initialHashedPassword.
Regression introduced in f496c3cbe4a6a2db88892d14609618e449744ed6.

Previously when we used security.initialRootPassword, the default
priority for this option was 1001, because it was a default value set by
the option itself.

With the mentioned commit, it is no longer an option default but a
mkDefault, which is priority 1000.

I'm setting this to 150 now, as test-instrumentation.nix is using this
for overriding other options and because I think it still makes it
possible to simple-override it, because if no priority is given, we get
priority 100.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/modules/virtualisation/docker-image.nix')
-rw-r--r--nixos/modules/virtualisation/docker-image.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/virtualisation/docker-image.nix b/nixos/modules/virtualisation/docker-image.nix
index ff276fc86a8e..cabb1712b6c0 100644
--- a/nixos/modules/virtualisation/docker-image.nix
+++ b/nixos/modules/virtualisation/docker-image.nix
@@ -56,7 +56,7 @@ in {
   services.openssh.startWhenNeeded = false;
 
   # Allow the user to login as root without password.
-  users.extraUsers.root.initialHashedPassword = mkDefault "";
+  users.extraUsers.root.initialHashedPassword = mkOverride 150 "";
 
   # Some more help text.
   services.mingetty.helpLine =