summary refs log tree commit diff
path: root/nixos/modules/virtualisation/containers.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2015-08-17 17:52:45 +0000
committerJan Malakhovski <oxij@oxij.org>2015-09-18 18:48:50 +0000
commit6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a (patch)
tree55e2983e16662e1074e9e668998253d31b429d59 /nixos/modules/virtualisation/containers.nix
parent33ae3f2fe4baeb4db19d3c90dbb6cd35b9373004 (diff)
downloadnixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.gz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.bz2
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.lz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.xz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.zst
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.zip
nixos: fix some types
Diffstat (limited to 'nixos/modules/virtualisation/containers.nix')
-rw-r--r--nixos/modules/virtualisation/containers.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/virtualisation/containers.nix b/nixos/modules/virtualisation/containers.nix
index 8d12c5a57fd9..02cf1fe46a55 100644
--- a/nixos/modules/virtualisation/containers.nix
+++ b/nixos/modules/virtualisation/containers.nix
@@ -108,7 +108,7 @@ in
             };
 
             hostAddress = mkOption {
-              type = types.nullOr types.string;
+              type = types.nullOr types.str;
               default = null;
               example = "10.231.136.1";
               description = ''
@@ -117,7 +117,7 @@ in
             };
 
             localAddress = mkOption {
-              type = types.nullOr types.string;
+              type = types.nullOr types.str;
               default = null;
               example = "10.231.136.2";
               description = ''