summary refs log tree commit diff
path: root/nixos/modules/virtualisation/azure-common.nix
diff options
context:
space:
mode:
authorAnmol Sethi <anmol@aubble.com>2016-10-01 13:23:56 -0400
committerAnmol Sethi <anmol@aubble.com>2016-10-01 13:23:56 -0400
commit6891bb1c5930b1691dcd808d14d8b9404e480f7a (patch)
treec3175409b0d26bea5a15bbcdc11b75f08d079ec0 /nixos/modules/virtualisation/azure-common.nix
parent98a8146428b28354182dbe1eff78e3f540f565a6 (diff)
downloadnixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar.gz
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar.bz2
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar.lz
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar.xz
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.tar.zst
nixlib-6891bb1c5930b1691dcd808d14d8b9404e480f7a.zip
openssh: support prohibit-password for permitRootLogin
See https://github.com/openssh/openssh-portable/commit/1dc8d93ce69d6565747eb44446ed117187621b26

I also made it the default.
Diffstat (limited to 'nixos/modules/virtualisation/azure-common.nix')
-rw-r--r--nixos/modules/virtualisation/azure-common.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/virtualisation/azure-common.nix b/nixos/modules/virtualisation/azure-common.nix
index 70a3d752f6d1..5cd2304a2953 100644
--- a/nixos/modules/virtualisation/azure-common.nix
+++ b/nixos/modules/virtualisation/azure-common.nix
@@ -24,7 +24,7 @@ with lib;
   # Allow root logins only using the SSH key that the user specified
   # at instance creation time, ping client connections to avoid timeouts
   services.openssh.enable = true;
-  services.openssh.permitRootLogin = "without-password";
+  services.openssh.permitRootLogin = "prohibit-password";
   services.openssh.extraConfig = ''
     ClientAliveInterval 180
   '';