summary refs log tree commit diff
path: root/nixos/modules/tasks/powertop.nix
diff options
context:
space:
mode:
authorLinus Heckemann <git@sphalerite.org>2017-10-07 21:45:43 +0100
committerLinus Heckemann <git@sphalerite.org>2017-10-07 21:48:50 +0100
commitfadb906b2f7091a9b973a6b1d79a4858e975b785 (patch)
treefff3b250f6027fd0ced061ea2a0efc2b805a2c69 /nixos/modules/tasks/powertop.nix
parent3fe7cddc304abb86e61a750a4f807270c7ca7825 (diff)
downloadnixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar.gz
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar.bz2
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar.lz
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar.xz
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.tar.zst
nixlib-fadb906b2f7091a9b973a6b1d79a4858e975b785.zip
powertop module: add kmod to path
powertop attempt to load some kernel modules like msr by calling
modprobe. This is the counterpart to
88e43eb39bcda5f8fdf41d566bc6799596177cd0 which has the powertop
executable search PATH for modprobe rather than hardcoding /sbin, and
actually adds the directory containing modprobe to its PATH for the
systemd service.
Diffstat (limited to 'nixos/modules/tasks/powertop.nix')
-rw-r--r--nixos/modules/tasks/powertop.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/tasks/powertop.nix b/nixos/modules/tasks/powertop.nix
index 0ec4974789b4..609831506e16 100644
--- a/nixos/modules/tasks/powertop.nix
+++ b/nixos/modules/tasks/powertop.nix
@@ -16,6 +16,7 @@ in {
       powertop = {
         wantedBy = [ "multi-user.target" ];
         description = "Powertop tunings";
+        path = [ pkgs.kmod ];
         serviceConfig = {
           Type = "oneshot";
           RemainAfterExit = "yes";