summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces.nix
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-02-21 15:41:37 +0100
committerRobin Gloster <mail@glob.in>2017-02-21 15:46:00 +0100
commitf1e6dc8750642ec001999c80da8f921207043b92 (patch)
tree48c7da84bc51b39503c0a4d37f0ecc62bafa43bb /nixos/modules/tasks/network-interfaces.nix
parentd0d5ea0cdfd56f95c5ec256f9583442bbc30f0fa (diff)
downloadnixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar.gz
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar.bz2
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar.lz
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar.xz
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.tar.zst
nixlib-f1e6dc8750642ec001999c80da8f921207043b92.zip
networking.defaultGateway{,6}: fix example
Diffstat (limited to 'nixos/modules/tasks/network-interfaces.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/tasks/network-interfaces.nix b/nixos/modules/tasks/network-interfaces.nix
index 898207ef7a3c..2841a221755e 100644
--- a/nixos/modules/tasks/network-interfaces.nix
+++ b/nixos/modules/tasks/network-interfaces.nix
@@ -358,7 +358,7 @@ in
       default = null;
       example = {
         address = "131.211.84.1";
-        device = "enp3s0";
+        interface = "enp3s0";
       };
       type = types.nullOr (types.coercedTo types.str gatewayCoerce (types.submodule gatewayOpts));
       description = ''
@@ -371,7 +371,7 @@ in
       default = null;
       example = {
         address = "2001:4d0:1e04:895::1";
-        device = "enp3s0";
+        interface = "enp3s0";
       };
       type = types.nullOr (types.coercedTo types.str gatewayCoerce (types.submodule gatewayOpts));
       description = ''