summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-04-07 17:30:41 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2016-04-25 18:15:52 +0200
commite16851b900cb62528427186e80f173c1954659b6 (patch)
tree348f47a8be6ff564a27e59085b4285c33e80c9b4 /nixos/modules/tasks/network-interfaces.nix
parent7e92ae903e10cec92f33e288050cc9b5d004fc16 (diff)
downloadnixlib-e16851b900cb62528427186e80f173c1954659b6.tar
nixlib-e16851b900cb62528427186e80f173c1954659b6.tar.gz
nixlib-e16851b900cb62528427186e80f173c1954659b6.tar.bz2
nixlib-e16851b900cb62528427186e80f173c1954659b6.tar.lz
nixlib-e16851b900cb62528427186e80f173c1954659b6.tar.xz
nixlib-e16851b900cb62528427186e80f173c1954659b6.tar.zst
nixlib-e16851b900cb62528427186e80f173c1954659b6.zip
networking module: Add some missing `literalExample`
Diffstat (limited to 'nixos/modules/tasks/network-interfaces.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/nixos/modules/tasks/network-interfaces.nix b/nixos/modules/tasks/network-interfaces.nix
index 0528012adfd8..c52bd904caec 100644
--- a/nixos/modules/tasks/network-interfaces.nix
+++ b/nixos/modules/tasks/network-interfaces.nix
@@ -523,7 +523,7 @@ in
 
     networking.bonds = mkOption {
       default = { };
-      example = {
+      example = literalExample {
         bond0 = {
           interfaces = [ "eth0" "wlan0" ];
           miimon = 100;
@@ -598,7 +598,7 @@ in
     networking.macvlans = mkOption {
       type = types.attrsOf types.optionSet;
       default = { };
-      example = {
+      example = literalExample {
         wan = {
           interface = "enp2s0";
           mode = "vepa";
@@ -629,7 +629,7 @@ in
     networking.sits = mkOption {
       type = types.attrsOf types.optionSet;
       default = { };
-      example = {
+      example = literalExample {
         hurricane = {
           remote = "10.0.0.1";
           local = "10.0.0.22";
@@ -688,7 +688,7 @@ in
 
     networking.vlans = mkOption {
       default = { };
-      example = {
+      example = literalExample {
         vlan0 = {
           id = 3;
           interface = "enp3s0";
@@ -727,7 +727,7 @@ in
 
     networking.wlanInterfaces = mkOption {
       default = { };
-      example = {
+      example = literalExample {
         "wlan-station0" = {
             device = "wlp6s0";
         };