summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-07-16 17:29:50 -0500
committerWilliam A. Kennington III <william@wkennington.com>2014-08-30 07:33:38 -0700
commit86c0f8c549c2ad728e06f8bc11d805fe760e7df8 (patch)
tree9c71752eb9b2a01e4173b598df7f68e9c8d7b496 /nixos/modules/tasks/network-interfaces.nix
parent1ff4b838758f36dc8c54995e104dd17ba08a65a4 (diff)
downloadnixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar.gz
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar.bz2
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar.lz
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar.xz
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.tar.zst
nixlib-86c0f8c549c2ad728e06f8bc11d805fe760e7df8.zip
Refactor nixos files relying on the old ipAddress / prefixLength / subnetMask attributes
Diffstat (limited to 'nixos/modules/tasks/network-interfaces.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/tasks/network-interfaces.nix b/nixos/modules/tasks/network-interfaces.nix
index e8c770d077c9..054784502eb2 100644
--- a/nixos/modules/tasks/network-interfaces.nix
+++ b/nixos/modules/tasks/network-interfaces.nix
@@ -254,10 +254,10 @@ in
     networking.interfaces = mkOption {
       default = {};
       example =
-        { eth0 = {
-            ipAddress = "131.211.84.78";
-            subnetMask = "255.255.255.128";
-          };
+        { eth0.ip4 = [ {
+            address = "131.211.84.78";
+            prefixLength = 25;
+          } ];
         };
       description = ''
         The configuration for each network interface.  If