summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-systemd.nix
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-11-24 12:06:07 -0800
committerWilliam A. Kennington III <william@wkennington.com>2014-11-26 11:22:03 -0800
commitc7d46687c5ed499bc558718eb04e90842b3eb0fd (patch)
tree968158abd7b5abeb2126af4d8a40e7d85fb9c35f /nixos/modules/tasks/network-interfaces-systemd.nix
parent2057d9087fa27413b2802c5ad54e5be5c2088f82 (diff)
downloadnixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar.gz
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar.bz2
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar.lz
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar.xz
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.tar.zst
nixlib-c7d46687c5ed499bc558718eb04e90842b3eb0fd.zip
nixos/network-interfaces: Support mac address and mtu universally
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-systemd.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-systemd.nix9
1 files changed, 0 insertions, 9 deletions
diff --git a/nixos/modules/tasks/network-interfaces-systemd.nix b/nixos/modules/tasks/network-interfaces-systemd.nix
index 134e800a26f6..690522a0fe7f 100644
--- a/nixos/modules/tasks/network-interfaces-systemd.nix
+++ b/nixos/modules/tasks/network-interfaces-systemd.nix
@@ -59,15 +59,6 @@ in
         networks."99-main" = genericNetwork mkDefault;
       }
       (mkMerge (flip map interfaces (i: {
-        links."40-${i.name}" = {
-          matchConfig.Name = i.name;
-          linkConfig =
-            (optionalAttrs (i.macAddress != null) {
-              MACAddress = i.macAddress;
-            }) // (optionalAttrs (i.mtu != null) {
-              MTUBytes = toString i.mtu;
-            });
-        };
         netdevs = mkIf i.virtual (
           let
             devType = if i.virtualType != null then i.virtualType