summary refs log tree commit diff
path: root/nixos/modules/tasks/network-interfaces-systemd.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2015-09-22 15:49:17 +0200
committerThomas Strobel <ts468@cam.ac.uk>2015-09-25 11:55:27 +0200
commit59bc47c9ede58f3cdfdfea18297375627ac99c6c (patch)
treec8f05bfa2bdc5d93e8345fef2dba0b10e69325e1 /nixos/modules/tasks/network-interfaces-systemd.nix
parent000a2108ba10df725065004e1f3d2fb793078f71 (diff)
downloadnixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar.gz
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar.bz2
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar.lz
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar.xz
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.tar.zst
nixlib-59bc47c9ede58f3cdfdfea18297375627ac99c6c.zip
nixos networking: add vswitch option
Add a configuration option for Open vSwitch that is
similar to the option for the Linux kernel ethernet
bridge.
Diffstat (limited to 'nixos/modules/tasks/network-interfaces-systemd.nix')
-rw-r--r--nixos/modules/tasks/network-interfaces-systemd.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/nixos/modules/tasks/network-interfaces-systemd.nix b/nixos/modules/tasks/network-interfaces-systemd.nix
index 8223c5a4941e..301ee43fd0e5 100644
--- a/nixos/modules/tasks/network-interfaces-systemd.nix
+++ b/nixos/modules/tasks/network-interfaces-systemd.nix
@@ -35,6 +35,9 @@ in
     assertions = [ {
       assertion = cfg.defaultGatewayWindowSize == null;
       message = "networking.defaultGatewayWindowSize is not supported by networkd.";
+    } {
+      assertion = cfg.vswitches == {};
+      message = "networking.vswichtes are not supported by networkd.";
     } ] ++ flip mapAttrsToList cfg.bridges (n: { rstp, ... }: {
       assertion = !rstp;
       message = "networking.bridges.${n}.rstp is not supported by networkd.";