summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-28 22:31:18 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-07-28 22:31:18 +0200
commitcb7b871bd62274cca90de5f14cf50e7f4a11ba00 (patch)
treed6bec654d9b4fbb2dadd3d77a9f54ed54e3e814e /nixos/modules/tasks/filesystems.nix
parent9bc1676e5ab6900697e7b34c50a3ca7b48f6a258 (diff)
downloadnixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar.gz
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar.bz2
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar.lz
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar.xz
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.tar.zst
nixlib-cb7b871bd62274cca90de5f14cf50e7f4a11ba00.zip
initrd: Include filesystem support for /nix, /var etc.
Diffstat (limited to 'nixos/modules/tasks/filesystems.nix')
-rw-r--r--nixos/modules/tasks/filesystems.nix11
1 files changed, 0 insertions, 11 deletions
diff --git a/nixos/modules/tasks/filesystems.nix b/nixos/modules/tasks/filesystems.nix
index d350bc1b5d0e..4de16a776d42 100644
--- a/nixos/modules/tasks/filesystems.nix
+++ b/nixos/modules/tasks/filesystems.nix
@@ -124,13 +124,6 @@ in
       description = "Names of supported filesystem types.";
     };
 
-    boot.initrd.supportedFilesystems = mkOption {
-      default = [ ];
-      example = [ "btrfs" ];
-      type = types.listOf types.string;
-      description = "Names of supported filesystem types in the initial ramdisk.";
-    };
-
   };
 
 
@@ -140,10 +133,6 @@ in
 
     boot.supportedFilesystems = map (fs: fs.fsType) fileSystems;
 
-    boot.initrd.supportedFilesystems =
-      map (fs: fs.fsType)
-        (filter (fs: fs.mountPoint == "/" || fs.neededForBoot) fileSystems);
-
     # Add the mount helpers to the system path so that `mount' can find them.
     system.fsPackages = [ pkgs.dosfstools ];