summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems.nix
diff options
context:
space:
mode:
authorKarn Kallio <kkallio@skami.org>2016-09-03 16:42:09 -0400
committerJoachim Fasting <joachifm@fastmail.fm>2016-09-04 03:19:32 +0200
commit8d977ead386cf29b8b395caca536bfaec9c36efe (patch)
treef1b2f08fbf44b98aa9daba2dd5e3709ecc34bbe8 /nixos/modules/tasks/filesystems.nix
parentd3ee483bfe6af094460527bdd5b2d02c71f11931 (diff)
downloadnixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar.gz
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar.bz2
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar.lz
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar.xz
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.tar.zst
nixlib-8d977ead386cf29b8b395caca536bfaec9c36efe.zip
setuid-wrappers : Prepare permissions for running wrappers
The new setuid-wrappers in /run cannot be executed by users due to:

1) the temporary directory does not allow access
2) the /run is mounted nosuid
Diffstat (limited to 'nixos/modules/tasks/filesystems.nix')
-rw-r--r--nixos/modules/tasks/filesystems.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/tasks/filesystems.nix b/nixos/modules/tasks/filesystems.nix
index 9ab1baeacb98..a66ece1020f8 100644
--- a/nixos/modules/tasks/filesystems.nix
+++ b/nixos/modules/tasks/filesystems.nix
@@ -287,7 +287,7 @@ in
     boot.specialFileSystems = {
       "/proc" = { fsType = "proc"; options = [ "nosuid" "noexec" "nodev" ]; };
       "/sys" = { fsType = "sysfs"; options = [ "nosuid" "noexec" "nodev" ]; };
-      "/run" = { fsType = "tmpfs"; options = [ "nosuid" "nodev" "strictatime" "mode=755" "size=${config.boot.runSize}" ]; };
+      "/run" = { fsType = "tmpfs"; options = [ "nodev" "strictatime" "mode=755" "size=${config.boot.runSize}" ]; };
       "/dev" = { fsType = "devtmpfs"; options = [ "nosuid" "strictatime" "mode=755" "size=${config.boot.devSize}" ]; };
       "/dev/shm" = { fsType = "tmpfs"; options = [ "nosuid" "nodev" "strictatime" "mode=1777" "size=${config.boot.devShmSize}" ]; };
       "/dev/pts" = { fsType = "devpts"; options = [ "nosuid" "noexec" "mode=620" "gid=${toString config.ids.gids.tty}" ]; };