summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2015-08-17 17:52:45 +0000
committerJan Malakhovski <oxij@oxij.org>2015-09-18 18:48:50 +0000
commit6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a (patch)
tree55e2983e16662e1074e9e668998253d31b429d59 /nixos/modules/tasks/filesystems.nix
parent33ae3f2fe4baeb4db19d3c90dbb6cd35b9373004 (diff)
downloadnixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.gz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.bz2
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.lz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.xz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.zst
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.zip
nixos: fix some types
Diffstat (limited to 'nixos/modules/tasks/filesystems.nix')
-rw-r--r--nixos/modules/tasks/filesystems.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/tasks/filesystems.nix b/nixos/modules/tasks/filesystems.nix
index ce21d9fe7621..ce9e3555b6cd 100644
--- a/nixos/modules/tasks/filesystems.nix
+++ b/nixos/modules/tasks/filesystems.nix
@@ -22,14 +22,14 @@ let
       device = mkOption {
         default = null;
         example = "/dev/sda";
-        type = types.uniq (types.nullOr types.string);
+        type = types.nullOr types.str;
         description = "Location of the device.";
       };
 
       label = mkOption {
         default = null;
         example = "root-partition";
-        type = types.uniq (types.nullOr types.string);
+        type = types.nullOr types.str;
         description = "Label of the device (if any).";
       };