summary refs log tree commit diff
path: root/nixos/modules/tasks/filesystems.nix
diff options
context:
space:
mode:
authorRichard Yang <rdjy@users.noreply.github.com>2017-08-30 09:50:29 +1000
committerFranz Pletz <fpletz@fnordicwalking.de>2017-08-30 01:50:29 +0200
commit64994b363804051e3d4b8f7916a5bc03a45b9e9a (patch)
treea763681c64bed29cf872c819e950cf9be9655251 /nixos/modules/tasks/filesystems.nix
parent5cf45626eb8cb0df5c236b752552ae561ad7f034 (diff)
downloadnixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar.gz
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar.bz2
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar.lz
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar.xz
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.tar.zst
nixlib-64994b363804051e3d4b8f7916a5bc03a45b9e9a.zip
tasks/filesystems: Make sure /dev/pts/ptmx is 0666 (#28490)
This is required for running commands likes screen and tmux, especially inside containers.

See also : https://www.kernel.org/doc/Documentation/filesystems/devpts.txt
Diffstat (limited to 'nixos/modules/tasks/filesystems.nix')
-rw-r--r--nixos/modules/tasks/filesystems.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/tasks/filesystems.nix b/nixos/modules/tasks/filesystems.nix
index 3951d617f6f1..1922d2924bc5 100644
--- a/nixos/modules/tasks/filesystems.nix
+++ b/nixos/modules/tasks/filesystems.nix
@@ -294,7 +294,7 @@ in
       "/run" = { fsType = "tmpfs"; options = [ "nosuid" "nodev" "strictatime" "mode=755" "size=${config.boot.runSize}" ]; };
       "/dev" = { fsType = "devtmpfs"; options = [ "nosuid" "strictatime" "mode=755" "size=${config.boot.devSize}" ]; };
       "/dev/shm" = { fsType = "tmpfs"; options = [ "nosuid" "nodev" "strictatime" "mode=1777" "size=${config.boot.devShmSize}" ]; };
-      "/dev/pts" = { fsType = "devpts"; options = [ "nosuid" "noexec" "mode=620" "gid=${toString config.ids.gids.tty}" ]; };
+      "/dev/pts" = { fsType = "devpts"; options = [ "nosuid" "noexec" "mode=620" "ptmxmode=0666" "gid=${toString config.ids.gids.tty}" ]; };
 
       # To hold secrets that shouldn't be written to disk (generally used for NixOps, harmless elsewhere)
       "/run/keys" = { fsType = "ramfs"; options = [ "nosuid" "nodev" "mode=750" "gid=${toString config.ids.gids.keys}" ]; };