summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
committerShea Levy <shea@shealevy.com>2018-03-01 14:38:53 -0500
commitfec543436d4d35dacde01a9e8b69a2781841f901 (patch)
treeb44b65ddbc7482e767d562f3f27c523c9ffbfcc0 /nixos/modules/system/boot/systemd.nix
parente70f61f5a19b00337082ab28a5013e0b440bda92 (diff)
downloadnixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.gz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.bz2
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.lz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.xz
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.tar.zst
nixlib-fec543436d4d35dacde01a9e8b69a2781841f901.zip
nixos: Move uses of stdenv.shell to runtimeShell.
Diffstat (limited to 'nixos/modules/system/boot/systemd.nix')
-rw-r--r--nixos/modules/system/boot/systemd.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/nixos/modules/system/boot/systemd.nix b/nixos/modules/system/boot/systemd.nix
index aff46ea861a2..92c9ee0c4691 100644
--- a/nixos/modules/system/boot/systemd.nix
+++ b/nixos/modules/system/boot/systemd.nix
@@ -241,37 +241,37 @@ let
         }
         (mkIf (config.preStart != "")
           { serviceConfig.ExecStartPre = makeJobScript "${name}-pre-start" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.preStart}
             '';
           })
         (mkIf (config.script != "")
           { serviceConfig.ExecStart = makeJobScript "${name}-start" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.script}
             '' + " " + config.scriptArgs;
           })
         (mkIf (config.postStart != "")
           { serviceConfig.ExecStartPost = makeJobScript "${name}-post-start" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.postStart}
             '';
           })
         (mkIf (config.reload != "")
           { serviceConfig.ExecReload = makeJobScript "${name}-reload" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.reload}
             '';
           })
         (mkIf (config.preStop != "")
           { serviceConfig.ExecStop = makeJobScript "${name}-pre-stop" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.preStop}
             '';
           })
         (mkIf (config.postStop != "")
           { serviceConfig.ExecStopPost = makeJobScript "${name}-post-stop" ''
-              #! ${pkgs.stdenv.shell} -e
+              #! ${pkgs.runtimeShell} -e
               ${config.postStop}
             '';
           })