summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-07-23 11:24:14 -0400
committerGitHub <noreply@github.com>2018-07-23 11:24:14 -0400
commitca0522a8424ef5305227681ceb345b61f31f0633 (patch)
tree7cefe50037e7eccecf18044d46c65a45e4adb787 /nixos/modules/system/boot/systemd.nix
parent92d576e04ba289fdd845c6b03f51c2046746e8fb (diff)
parent76c4c7b9de8930d82af8064d2abde5f3b492cb0a (diff)
downloadnixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar.gz
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar.bz2
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar.lz
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar.xz
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.tar.zst
nixlib-ca0522a8424ef5305227681ceb345b61f31f0633.zip
Merge pull request #41970 from aneeshusa/enable-building-systemd-without-libmicrohttpd
nixos/systemd: Allow building systemd without libmicrohttpd
Diffstat (limited to 'nixos/modules/system/boot/systemd.nix')
-rw-r--r--nixos/modules/system/boot/systemd.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/system/boot/systemd.nix b/nixos/modules/system/boot/systemd.nix
index ed149f4791bf..3e75941c193e 100644
--- a/nixos/modules/system/boot/systemd.nix
+++ b/nixos/modules/system/boot/systemd.nix
@@ -70,8 +70,6 @@ let
       "systemd-journald.socket"
       "systemd-journald.service"
       "systemd-journal-flush.service"
-      "systemd-journal-gatewayd.socket"
-      "systemd-journal-gatewayd.service"
       "systemd-journal-catalog-update.service"
       "systemd-journald-audit.socket"
       "systemd-journald-dev-log.socket"
@@ -160,8 +158,10 @@ let
       "systemd-binfmt.service"
       "systemd-exit.service"
       "systemd-update-done.service"
-    ]
-    ++ cfg.additionalUpstreamSystemUnits;
+    ] ++ optionals config.services.journald.enableHttpGateway [
+      "systemd-journal-gatewayd.socket"
+      "systemd-journal-gatewayd.service"
+    ] ++ cfg.additionalUpstreamSystemUnits;
 
   upstreamSystemWants =
     [ "sysinit.target.wants"