summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd.nix
diff options
context:
space:
mode:
authorJaka Hudoklin <jakahudoklin@gmail.com>2015-11-16 15:07:10 +0100
committerJaka Hudoklin <jakahudoklin@gmail.com>2015-11-16 15:12:28 +0100
commitb9291616a6d7c3747f45c7d519a4da03a17a514e (patch)
treee8062ef4d438606366827c6a1e2102dc65514e72 /nixos/modules/system/boot/systemd.nix
parent88f5cfc1268dfd75556f8d890d841efe56243fd4 (diff)
downloadnixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar.gz
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar.bz2
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar.lz
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar.xz
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.tar.zst
nixlib-b9291616a6d7c3747f45c7d519a4da03a17a514e.zip
systemd module: Add OnFailure to systemd common unit options
Diffstat (limited to 'nixos/modules/system/boot/systemd.nix')
-rw-r--r--nixos/modules/system/boot/systemd.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/systemd.nix b/nixos/modules/system/boot/systemd.nix
index 0b7647093e0f..d145baeebe93 100644
--- a/nixos/modules/system/boot/systemd.nix
+++ b/nixos/modules/system/boot/systemd.nix
@@ -199,6 +199,8 @@ let
           { X-Restart-Triggers = toString config.restartTriggers; }
         // optionalAttrs (config.description != "") {
           Description = config.description;
+        } // optionalAttrs (config.onFailure != []) {
+          OnFailure = toString config.onFailure;
         };
     };
   };