summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd.nix
diff options
context:
space:
mode:
authorTad Fisher <tadfisher@gmail.com>2018-10-28 13:41:21 -0700
committerTad Fisher <tadfisher@gmail.com>2018-10-28 13:41:21 -0700
commit8520839b6a48c090ea3f29dd334b1ba4744b45a7 (patch)
treeb9ca427df8e1a0aeeb775e87c5d3022d5f4bfa1d /nixos/modules/system/boot/systemd.nix
parente62214150f248921d09934a865d24bf4c54d124e (diff)
downloadnixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar.gz
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar.bz2
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar.lz
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar.xz
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.tar.zst
nixlib-8520839b6a48c090ea3f29dd334b1ba4744b45a7.zip
nixos/systemd: support "suspend-then-hibernate" logind option
Diffstat (limited to 'nixos/modules/system/boot/systemd.nix')
-rw-r--r--nixos/modules/system/boot/systemd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/systemd.nix b/nixos/modules/system/boot/systemd.nix
index a1412bc32904..8bf5f1d4303d 100644
--- a/nixos/modules/system/boot/systemd.nix
+++ b/nixos/modules/system/boot/systemd.nix
@@ -387,7 +387,7 @@ let
 
   logindHandlerType = types.enum [
     "ignore" "poweroff" "reboot" "halt" "kexec" "suspend"
-    "hibernate" "hybrid-sleep" "lock"
+    "hibernate" "hybrid-sleep" "suspend-then-hibernate" "lock"
   ];
 
 in