summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd-unit-options.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2018-05-13 01:15:37 +0000
committerJan Malakhovski <oxij@oxij.org>2018-05-13 01:15:37 +0000
commitfb2a8d66699c96d6a687eb71ebfcca08e3405037 (patch)
tree036439472ada3b356323c26bb8098af768acca8f /nixos/modules/system/boot/systemd-unit-options.nix
parent44d612d6e5188cf6fcb3f2fefb0116e2c979e9c3 (diff)
downloadnixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar.gz
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar.bz2
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar.lz
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar.xz
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.tar.zst
nixlib-fb2a8d66699c96d6a687eb71ebfcca08e3405037.zip
nixos: systemd.services.*.environment: fix type
Diffstat (limited to 'nixos/modules/system/boot/systemd-unit-options.nix')
-rw-r--r--nixos/modules/system/boot/systemd-unit-options.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/systemd-unit-options.nix b/nixos/modules/system/boot/systemd-unit-options.nix
index 5255f1a1b97a..2cff25a8c854 100644
--- a/nixos/modules/system/boot/systemd-unit-options.nix
+++ b/nixos/modules/system/boot/systemd-unit-options.nix
@@ -217,7 +217,7 @@ in rec {
 
     environment = mkOption {
       default = {};
-      type = with types; attrsOf (nullOr (either str package));
+      type = with types; attrsOf (nullOr (either str (either path package)));
       example = { PATH = "/foo/bar/bin"; LANG = "nl_NL.UTF-8"; };
       description = "Environment variables passed to the service's processes.";
     };