summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd-unit-options.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2016-09-01 00:39:36 +0200
committerProfpatsch <mail@profpatsch.de>2016-09-01 00:39:36 +0200
commit488f0d9cb362342081ece69e6ef52cd4adf4fa5a (patch)
treef51b5512603097fdca734ca2166b0ad9b14b1e2a /nixos/modules/system/boot/systemd-unit-options.nix
parentc4e67a3dc9bf9d592a0c883d0fb124c34eb8378f (diff)
downloadnixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar.gz
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar.bz2
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar.lz
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar.xz
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.tar.zst
nixlib-488f0d9cb362342081ece69e6ef52cd4adf4fa5a.zip
systemd-unit-options: startAt can be a list
OnCalendar entrys can be specified multiple times in a systemd timer, to
make more complex scheduling possible.

Tested by manually checking the timer generated by the following:

    systemd = {
      services.huhu = {
        description = "meh";
        wantedBy = [ "default.target" ];
        serviceConfig.ExecStart = "/bin/sh -c 'printf HUHU!'";
        startAt = [ "*:*:0/30" "*:0/1:15" ];
      };
    };

It prints HUHU to the log at seconds 0, 15 and 30 of each minute.
Diffstat (limited to 'nixos/modules/system/boot/systemd-unit-options.nix')
-rw-r--r--nixos/modules/system/boot/systemd-unit-options.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/systemd-unit-options.nix b/nixos/modules/system/boot/systemd-unit-options.nix
index f2a22e4ada8a..f4892244de47 100644
--- a/nixos/modules/system/boot/systemd-unit-options.nix
+++ b/nixos/modules/system/boot/systemd-unit-options.nix
@@ -309,7 +309,7 @@ in rec {
     };
 
     startAt = mkOption {
-      type = types.str;
+      type = with types; either str (listOf str);
       default = "";
       example = "Sun 14:00:00";
       description = ''