summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd-unit-options.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:24:55 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-26 18:24:55 +0100
commit14cd8bc24874b33e87ec08ddb6d47502e76f17b0 (patch)
tree933c578167bf6c01fa1d1e2529c00410e9766b28 /nixos/modules/system/boot/systemd-unit-options.nix
parent2b1f21249445991940c9d3ebbc54ce41b1eaf9c0 (diff)
downloadnixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar.gz
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar.bz2
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar.lz
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar.xz
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.tar.zst
nixlib-14cd8bc24874b33e87ec08ddb6d47502e76f17b0.zip
Allow services to specify a pre-stop script
Diffstat (limited to 'nixos/modules/system/boot/systemd-unit-options.nix')
-rw-r--r--nixos/modules/system/boot/systemd-unit-options.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nixos/modules/system/boot/systemd-unit-options.nix b/nixos/modules/system/boot/systemd-unit-options.nix
index 4eb3f1a43a65..c0518599f17a 100644
--- a/nixos/modules/system/boot/systemd-unit-options.nix
+++ b/nixos/modules/system/boot/systemd-unit-options.nix
@@ -210,6 +210,14 @@ in rec {
       '';
     };
 
+    preStop = mkOption {
+      type = types.lines;
+      default = "";
+      description = ''
+        Shell commands executed to stop the service.
+      '';
+    };
+
     postStop = mkOption {
       type = types.lines;
       default = "";