summary refs log tree commit diff
path: root/nixos/modules/system/boot/systemd-nspawn.nix
diff options
context:
space:
mode:
authorGiumo X. Clanjor (哆啦比猫/兰威举) <cjxgm@126.com>2017-07-04 21:12:47 +0800
committerGitHub <noreply@github.com>2017-07-04 21:12:47 +0800
commit87cbb862148fac257c991949f6cebd9ce6c51a2a (patch)
treeb94c6bb3ffb06f965c5b3560176d6029e9ee9b8f /nixos/modules/system/boot/systemd-nspawn.nix
parent51c481bdcc30e581dc9f3221530acd8e299b89c8 (diff)
downloadnixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar.gz
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar.bz2
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar.lz
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar.xz
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.tar.zst
nixlib-87cbb862148fac257c991949f6cebd9ce6c51a2a.zip
systemd.nspawn: fix missing suffix
Fix files placed in `/etc/systemd/nspawn/` missing `.nspawn` suffix
Diffstat (limited to 'nixos/modules/system/boot/systemd-nspawn.nix')
-rw-r--r--nixos/modules/system/boot/systemd-nspawn.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/system/boot/systemd-nspawn.nix b/nixos/modules/system/boot/systemd-nspawn.nix
index 8fa9f8b795e5..64b3b8b584e3 100644
--- a/nixos/modules/system/boot/systemd-nspawn.nix
+++ b/nixos/modules/system/boot/systemd-nspawn.nix
@@ -110,7 +110,7 @@ in {
 
   config =
     let
-      units = mapAttrs' (n: v: nameValuePair "${n}.nspawn" (instanceToUnit n v)) cfg;
+      units = mapAttrs' (n: v: let nspawnFile = "${n}.nspawn"; in nameValuePair nspawnFile (instanceToUnit nspawnFile v)) cfg;
     in mkIf (cfg != {}) {
 
       environment.etc."systemd/nspawn".source = generateUnits "nspawn" units [] [];